Ansible で “Could not detect which major revision of yum is in use, which is required to determine module backend.” エラーが発生する



Ansible で次のエラーが発生することがあります。

このエラーは ansible が旧来の yum(yum3) から次世代の yum4 (dnf) かを判別できないと言うことです。

しかし、このエラーが出たときには、対象サーバーの ansible 用のユーザーが wheel 権限が無く、sudo できないという可能性があります。

対象ホストにおいて

のようにユーザーを wheel グループに追加するだけで解消するかもしれません。


コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

  • キュア子の紹介

人気記事ランキング