[DEPRECATION] requiring “RMagick” is deprecated. Use “rmagick” instead のエラーメッセージ



キュアコード株式会社ではタスク管理に Redmine を使っています。 以下のように cron に登録して Redmine であと3日以内に期限が来るチケット(もしくは期日を過ぎたチケット)の一覧をメールするようにしています。 しかし Redmine 3.0 系にアップデートしてから cron 実行のタイミングで以下のようなアラートメールがくるようになりました。 RMagick という綴りは非推奨になり、代わりに rmagick と綴らなければならないというエラーなのですが、実は Redmine のソースを書き換えただけでは解決しません。 このエラーは Redmine を 3.0.3 (本稿公開時点の最新版は 3.1.0 です)にアップデートしたところ、cron 実行時にエラーは出なくなりました。 Ruby on Rails もセキュリティアップデートやバグ修正が出ていますので、常に最新版を使うようにしていきましょう。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

  • キュア子の紹介

人気記事ランキング